MPG LinuxCNC 2.9 USB CNC WHB04B-4 WHB04B-6 Debian9 Wędka , Kółko ręczne, Wireless Pendant

Dyskusje dotyczące działania obsługi programu LinuxCNC

szatri
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 21
Posty: 171
Rejestracja: 23 lut 2011, 15:12
Lokalizacja: KONFEDERACJA

Re: MPG LinuxCNC 2.9 USB CNC WHB04B-4 WHB04B-6 Debian9 Wędka , Kółko ręczne, Wireless Pendant

#131

Post napisał: szatri » 08 cze 2021, 14:59

Kod: Zaznacz cały

[email protected]bian:~$ sudo apt-get clean
[sudo] password for cnc: 
[email protected]:~$ sudo apt-get install debian-archive-keyring
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
debian-archive-keyring jest już w najnowszej wersji.
Należy uruchomić "apt-get -f install", aby naprawić poniższe problemy:
Następujące pakiety mają niespełnione zależności:
 cpp-6 : Wymaga: gcc-6-base (= 6.3.0-18+deb9u1) ale nie da się go zainstalować
 dblatex : Wymaga: texlive-bibtex-extra ale nie zostanie zainstalowany
           Wymaga: texlive-extra-utils ale nie zostanie zainstalowany
           Wymaga: texlive-latex-extra ale nie zostanie zainstalowany
           Wymaga: texlive-science ale nie zostanie zainstalowany
           Wymaga: python:any (< 2.8) ale nie da się go zainstalować
           Wymaga: python:any (>= 2.7.5-5~) ale nie da się go zainstalować
           Poleca: dblatex-doc (= 0.3.9-3) ale nie da się go zainstalować
 dpkg-dev : Wymaga: libdpkg-perl (= 1.16.18) ale 1.18.25 ma zostać zainstalowany
 dvipng : Wymaga: texlive-base-bin
 jadetex : Wymaga: texlive-latex-base ale nie zostanie zainstalowany
           Wymaga: texlive-fonts-recommended ale nie zostanie zainstalowany
           Wymaga: texlive-generic-recommended ale nie zostanie zainstalowany
 latex-beamer : Wymaga: texlive-latex-base ale nie zostanie zainstalowany
 libalgorithm-diff-xs-perl : Wymaga: perlapi-5.14.2
 libc-dev-bin : Wymaga: libc6 (< 2.14) ale 2.24-11+deb9u4 ma zostać zainstalowany
 libc6-dev : Wymaga: libc6 (= 2.13-38+deb7u12) ale 2.24-11+deb9u4 ma zostać zainstalowany
 libc6-i686 : Wymaga wstępnie: libc6 (= 2.13-38+deb7u12) ale 2.24-11+deb9u4 ma zostać zainstalowany
 libcairo-perl : Wymaga: perlapi-5.14.2
 libclass-c3-xs-perl : Wymaga: perlapi-5.14.2
 libclass-load-xs-perl : Wymaga: perlapi-5.14.2
 libclone-perl : Wymaga: perlapi-5.14.2
 libdevmapper1.02.1 : Wymaga: libudev1 (>= 183) ale nie da się go zainstalować
 libencode-hanextra-perl : Wymaga: perlapi-5.14.2
 libencode-jis2k-perl : Wymaga: perlapi-5.14.2
 libfile-fcntllock-perl : Wymaga: perlapi-5.14.2
 libglib-perl : Wymaga: perlapi-5.14.2
 libgtk2-perl : Wymaga: perlapi-5.14.2
 libhtml-parser-perl : Wymaga: perlapi-5.14.2
 libhtml-tidy-perl : Wymaga: perlapi-5.14.2
 libjson-xs-perl : Wymaga: perlapi-5.14.2
 liblist-moreutils-perl : Wymaga: perlapi-5.14.2
 liblocale-gettext-perl : Wymaga wstępnie: perlapi-5.14.2
 liblvm2app2.2 : Wymaga: libudev1 (>= 183) ale nie da się go zainstalować
 libmoose-perl : Wymaga: perlapi-5.14.2
 libnet-dbus-perl : Wymaga: perlapi-5.14.2
 libnet-ssleay-perl : Wymaga: perlapi-5.14.2
 libpackage-stash-xs-perl : Wymaga: perlapi-5.14.2
 libpango-perl : Wymaga: perlapi-5.14.2
 libparams-classify-perl : Wymaga: perlapi-5.14.2
 libparams-util-perl : Wymaga: perlapi-5.14.2
 libparams-validate-perl : Wymaga: perlapi-5.14.2
 libperl5.14 : Wymaga: perl-base (= 5.14.2-21+deb7u6) ale 5.24.1-3+deb9u7 ma zostać zainstalowany
 libselinux1-dev : Wymaga: libselinux1 (= 2.1.9-5) ale 2.6-3+b3 ma zostać zainstalowany
 libsgml-parser-opensp-perl : Wymaga: perlapi-5.14.2
 libsub-identify-perl : Wymaga: perlapi-5.14.2
 libsub-name-perl : Wymaga: perlapi-5.14.2
 libterm-readkey-perl : Wymaga: perlapi-5.14.2
 libtext-charwidth-perl : Wymaga: perlapi-5.14.2
 libtext-iconv-perl : Wymaga: perlapi-5.14.2
 libuuid-perl : Wymaga: perlapi-5.14.2
 libvariable-magic-perl : Wymaga: perlapi-5.14.2
 libxml-libxml-perl : Wymaga: perlapi-5.14.2
 libxml-parser-perl : Wymaga: perlapi-5.14.2
 locales : Wymaga: libc-bin (> 2.24) ale 2.13-38+deb7u12 ma zostać zainstalowany
           Wymaga: libc-l10n (> 2.24) ale nie da się go zainstalować
 lsof : Wymaga: libperl4-corelibs-perl lub
                perl (< 5.12.3-7) ale 5.24.1-3+deb9u7 ma zostać zainstalowany
 nfs-common : Wymaga: init-system-helpers (>= 1.18~) ale nie da się go zainstalować
              Wymaga: keyutils ale nie zostanie zainstalowany
 perlmagick : Wymaga: perlapi-5.14.2
 prosper : Wymaga: texlive-latex-base ale nie zostanie zainstalowany
 texinfo : Wymaga: tex-common (>= 6) ale 3.15 ma zostać zainstalowany
 texlive : Wymaga: texlive-fonts-recommended (>= 2016.20170123-2) ale nie zostanie zainstalowany
           Wymaga: texlive-latex-base (>= 2016.20170123-2) ale nie zostanie zainstalowany
           Wymaga: texlive-latex-recommended (>= 2016.20170123-2) ale 2012.20120611-5+deb7u1 ma zostać zainstalowany
 texlive-base : Wymaga: texlive-binaries (>= 2012.20120516) ale nie zostanie zainstalowany
                Wymaga: luatex (>= 0.70.1) ale nie zostanie zainstalowany
 texlive-latex-recommended : Wymaga: texlive-binaries (>= 2012-0) ale nie zostanie zainstalowany
                             Wymaga: texlive-latex-base (>= 2012.20120516) ale nie zostanie zainstalowany
 texlive-luatex : Wymaga: texlive-binaries (>= 2012-0) ale nie zostanie zainstalowany
                  Wymaga: luatex (>= 0.70.1) ale nie zostanie zainstalowany
 texlive-math-extra : Wymaga: texlive-binaries (>= 2012-0) ale nie zostanie zainstalowany
                      Wymaga: texlive-latex-base (>= 2012.20120516) ale nie zostanie zainstalowany
                      Wymaga: texlive-fonts-recommended (>= 2012.20120516) ale nie zostanie zainstalowany
 texlive-pictures : Wymaga: luatex ale nie zostanie zainstalowany
                    Wymaga: texlive-binaries (>= 2012-0) ale nie zostanie zainstalowany
 texlive-pstricks : Wymaga: texlive-binaries (>= 2012-0) ale nie zostanie zainstalowany
                    Wymaga: texlive-generic-recommended (>= 2012.20120516) ale nie zostanie zainstalowany
                    Poleca: texlive-extra-utils ale nie zostanie zainstalowany
                    Poleca: texlive-font-utils ale nie zostanie zainstalowany
 tipa : Wymaga: texlive-latex-base ale nie zostanie zainstalowany
        Wymaga: texlive-base-bin
W: Duplicate sources.list entry http://buildbot.linuxcnc.org/ wheezy/master-rt i386 Packages (/var/lib/apt/lists/buildbot.linuxcnc.org_dists_wheezy_master-rt_binary-i386_Packages)
W: Duplicate sources.list entry http://buildbot.linuxcnc.org/ wheezy/master-rt i386 Packages (/var/lib/apt/lists/buildbot.linuxcnc.org_dists_wheezy_master-rt_binary-i386_Packages)
W: Należy uruchomić apt-get update aby naprawić te problemy.
E: Niespełnione zależności. Proszę spróbować wykonać "apt-get -f install" bez pakietów (lub podać rozwiązanie).

Kod: Zaznacz cały

[email protected]:~$ sudo apt-get -f install 
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Naprawianie zależności... nie udało się.
Następujące pakiety mają niespełnione zależności:
 cpp-6 : Wymaga: gcc-6-base (= 6.3.0-18+deb9u1) ale nie da się go zainstalować
 dblatex : Wymaga: texlive-bibtex-extra ale nie jest zainstalowany
           Wymaga: texlive-extra-utils ale nie jest zainstalowany
           Wymaga: texlive-latex-extra ale nie jest zainstalowany
           Wymaga: texlive-science ale nie jest zainstalowany
           Wymaga: python:any (< 2.8) ale nie da się go zainstalować
           Wymaga: python:any (>= 2.7.5-5~) ale nie da się go zainstalować
           Poleca: dblatex-doc (= 0.3.9-3) ale nie da się go zainstalować
 dpkg-dev : Wymaga: libdpkg-perl (= 1.16.18) ale 1.18.25 jest zainstalowany
 dvipng : Wymaga: texlive-base-bin
 jadetex : Wymaga: texlive-latex-base ale nie jest zainstalowany
           Wymaga: texlive-fonts-recommended ale nie jest zainstalowany
           Wymaga: texlive-generic-recommended ale nie jest zainstalowany
 latex-beamer : Wymaga: texlive-latex-base ale nie jest zainstalowany
 libalgorithm-diff-xs-perl : Wymaga: perlapi-5.14.2
 libc-dev-bin : Wymaga: libc6 (< 2.14) ale 2.24-11+deb9u4 jest zainstalowany
 libc6-dev : Wymaga: libc6 (= 2.13-38+deb7u12) ale 2.24-11+deb9u4 jest zainstalowany
 libc6-i686 : Wymaga wstępnie: libc6 (= 2.13-38+deb7u12) ale 2.24-11+deb9u4 jest zainstalowany
 libcairo-perl : Wymaga: perlapi-5.14.2
 libclass-c3-xs-perl : Wymaga: perlapi-5.14.2
 libclass-load-xs-perl : Wymaga: perlapi-5.14.2
 libclone-perl : Wymaga: perlapi-5.14.2
 libdevmapper1.02.1 : Wymaga: libudev1 (>= 183) ale nie da się go zainstalować
 libencode-hanextra-perl : Wymaga: perlapi-5.14.2
 libencode-jis2k-perl : Wymaga: perlapi-5.14.2
 libfile-fcntllock-perl : Wymaga: perlapi-5.14.2
 libglib-perl : Wymaga: perlapi-5.14.2
 libgtk2-perl : Wymaga: perlapi-5.14.2
 libhtml-parser-perl : Wymaga: perlapi-5.14.2
 libhtml-tidy-perl : Wymaga: perlapi-5.14.2
 libjson-xs-perl : Wymaga: perlapi-5.14.2
 liblist-moreutils-perl : Wymaga: perlapi-5.14.2
 liblocale-gettext-perl : Wymaga wstępnie: perlapi-5.14.2
 liblvm2app2.2 : Wymaga: libudev1 (>= 183) ale nie da się go zainstalować
 libmoose-perl : Wymaga: perlapi-5.14.2
 libnet-dbus-perl : Wymaga: perlapi-5.14.2
 libnet-ssleay-perl : Wymaga: perlapi-5.14.2
 libpackage-stash-xs-perl : Wymaga: perlapi-5.14.2
 libpango-perl : Wymaga: perlapi-5.14.2
 libparams-classify-perl : Wymaga: perlapi-5.14.2
 libparams-util-perl : Wymaga: perlapi-5.14.2
 libparams-validate-perl : Wymaga: perlapi-5.14.2
 libperl5.14 : Wymaga: perl-base (= 5.14.2-21+deb7u6) ale 5.24.1-3+deb9u7 jest zainstalowany
 libselinux1-dev : Wymaga: libselinux1 (= 2.1.9-5) ale 2.6-3+b3 jest zainstalowany
 libsgml-parser-opensp-perl : Wymaga: perlapi-5.14.2
 libsub-identify-perl : Wymaga: perlapi-5.14.2
 libsub-name-perl : Wymaga: perlapi-5.14.2
 libterm-readkey-perl : Wymaga: perlapi-5.14.2
 libtext-charwidth-perl : Wymaga: perlapi-5.14.2
 libtext-iconv-perl : Wymaga: perlapi-5.14.2
 libuuid-perl : Wymaga: perlapi-5.14.2
 libvariable-magic-perl : Wymaga: perlapi-5.14.2
 libxml-libxml-perl : Wymaga: perlapi-5.14.2
 libxml-parser-perl : Wymaga: perlapi-5.14.2
 locales : Wymaga: libc-bin (> 2.24) ale 2.13-38+deb7u12 jest zainstalowany
           Wymaga: libc-l10n (> 2.24) ale nie da się go zainstalować
 lsof : Wymaga: libperl4-corelibs-perl lub
                perl (< 5.12.3-7) ale 5.24.1-3+deb9u7 jest zainstalowany
 nfs-common : Wymaga: init-system-helpers (>= 1.18~) ale nie da się go zainstalować
              Wymaga: keyutils ale nie jest zainstalowany
 perlmagick : Wymaga: perlapi-5.14.2
 prosper : Wymaga: texlive-latex-base ale nie jest zainstalowany
 texinfo : Wymaga: tex-common (>= 6) ale 3.15 jest zainstalowany
 texlive : Wymaga: texlive-fonts-recommended (>= 2016.20170123-2) ale nie jest zainstalowany
           Wymaga: texlive-latex-base (>= 2016.20170123-2) ale nie jest zainstalowany
           Wymaga: texlive-latex-recommended (>= 2016.20170123-2) ale 2012.20120611-5+deb7u1 jest zainstalowany
 texlive-base : Wymaga: texlive-binaries (>= 2012.20120516) ale nie jest zainstalowany
                Wymaga: luatex (>= 0.70.1) ale nie jest zainstalowany
 texlive-latex-recommended : Wymaga: texlive-binaries (>= 2012-0) ale nie jest zainstalowany
                             Wymaga: texlive-latex-base (>= 2012.20120516) ale nie jest zainstalowany
 texlive-luatex : Wymaga: texlive-binaries (>= 2012-0) ale nie jest zainstalowany
                  Wymaga: luatex (>= 0.70.1) ale nie jest zainstalowany
 texlive-math-extra : Wymaga: texlive-binaries (>= 2012-0) ale nie jest zainstalowany
                      Wymaga: texlive-latex-base (>= 2012.20120516) ale nie jest zainstalowany
                      Wymaga: texlive-fonts-recommended (>= 2012.20120516) ale nie jest zainstalowany
 texlive-pictures : Wymaga: luatex ale nie jest zainstalowany
                    Wymaga: texlive-binaries (>= 2012-0) ale nie jest zainstalowany
 texlive-pstricks : Wymaga: texlive-binaries (>= 2012-0) ale nie jest zainstalowany
                    Wymaga: texlive-generic-recommended (>= 2012.20120516) ale nie jest zainstalowany
                    Poleca: texlive-extra-utils ale nie jest zainstalowany
                    Poleca: texlive-font-utils ale nie jest zainstalowany
 tipa : Wymaga: texlive-latex-base ale nie jest zainstalowany
        Wymaga: texlive-base-bin
E: Błąd, pkgProblemResolver::Resolve zwrócił błąd, może to być spowodowane zatrzymanymi pakietami.
E: Nie udało się naprawić zależności
[email protected]:~$ 



Awatar użytkownika

gluk
Sympatyk forum poziom 1 (min. 40)
Sympatyk forum poziom 1 (min. 40)
Posty w temacie: 7
Posty: 47
Rejestracja: 31 paź 2020, 10:59
Lokalizacja: Polska
Kontakt:

Re: MPG LinuxCNC 2.9 USB CNC WHB04B-4 WHB04B-6 Debian9 Wędka , Kółko ręczne, Wireless Pendant

#132

Post napisał: gluk » 08 cze 2021, 16:08

szatri pisze:Do klepałem jakieś repozytorium z Debiana stretch i 1,5gb mi się chce zauktolizować, zobaczymy co będzie bo choć ten pakiet pokazuje że jest w wersji potrzebnej.


i są niestety tego efekty np:

Kod: Zaznacz cały

...
libc-dev-bin : Wymaga: libc6 (< 2.14) ale 2.24-11+deb9u4 jest zainstalowany
...
czyli masz już zainstalowaną libc6 2.24-11+deb9u4 z debiana stretch, a inna niezaktalizowana biblioteka libc-dev-bin wymaga wersji nie wyższej jak 2.14. System nie jest w stanie tego ogarnąć automatycznie.


szatri
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 21
Posty: 171
Rejestracja: 23 lut 2011, 15:12
Lokalizacja: KONFEDERACJA

Re: MPG LinuxCNC 2.9 USB CNC WHB04B-4 WHB04B-6 Debian9 Wędka , Kółko ręczne, Wireless Pendant

#133

Post napisał: szatri » 09 cze 2021, 17:45

gluk pisze:Ktoś inny z wheezy uaktualnianym na bieżąco do 2018 roku (lub dalej do kiedy repozytoria pakietów dla wheezy były na serwerach) będzie miał być może lib-gtk3-dev w wersji ~3.24 i zainstaluje tę wędkę.

pobrałem wersje oficjalna dediana 7,11, niby ostatni wypust, i niestety nie było w nim tego pakietu w wymaganej wersji wiec wszem ogłaszam że sie poddałem z tym ustrojstwem (tym pakietem) i zainstalowałem deb10 z linuxcnc.org
test skoczył max do 30tys wiec jest nadzieja ze podzała.


szatri
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 21
Posty: 171
Rejestracja: 23 lut 2011, 15:12
Lokalizacja: KONFEDERACJA

Re: MPG LinuxCNC 2.9 USB CNC WHB04B-4 WHB04B-6 Debian9 Wędka , Kółko ręczne, Wireless Pendant

#134

Post napisał: szatri » 10 cze 2021, 23:25

Zainstalowałem wczoraj deb10, zrobiłem instrukcje jak dla deb9, wszystko się skompilowalo ale jest problem z hal, wcale nie odbiera żadnych komend z wędki, (lsusb pokazuje), dziś zainstalowałem deb9 ponownie wedle poradnika dla deb9 i ponownie ten sam rezultat, nie odbiera sygnałów (wetka jest sprawna bo działa po winda)


szatri
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 21
Posty: 171
Rejestracja: 23 lut 2011, 15:12
Lokalizacja: KONFEDERACJA

Re: MPG LinuxCNC 2.9 USB CNC WHB04B-4 WHB04B-6 Debian9 Wędka , Kółko ręczne, Wireless Pendant

#135

Post napisał: szatri » 12 cze 2021, 18:02

W końcu dziś sukces, działa pod deb 10 z lcnc2,9, problemem był plik bin xhc-whb04b-6 który to nie wiem jakim sposobem się nadpisał na oryginalny (możne skopiowanie nie poszło bo trzeba to na rocie robić i nie przy uwarzyłem, nie wiem), dziś jeszcze raz przerobiłem poradnik i o dziwo działa, pozostaje kwestia kalibracji/ ustawienia bo nie przełącza prędkości ale to temat na osobny watek.

ODPOWIEDZ Poprzedni tematNastępny temat

Wróć do „LinuxCNC (dawniej EMC2)”