PikoCNC 5.0.0 i OpenGL

Problem z karta graficzną

Dyskusje dotyczące działania obsługi programu PikoCNC

Autor tematu
Ras
Nowy użytkownik, używaj wyszukiwarki
Nowy użytkownik, używaj wyszukiwarki
Posty w temacie: 2
Posty: 2
Rejestracja: 28 cze 2020, 11:30

PikoCNC 5.0.0 i OpenGL

#1

Post napisał: Ras » 28 cze 2020, 12:09

Cześć,
mam w PC (Win10) zintegrowaną grafikę Intel HD Graphics 2000.
PikoCNC 5.0.0 po uruchomieniu wyświetla taki komunikat
Brak podglądu !
karta graficzna nie obsługuje OpenGL >= 1.5

Sprawdziłem aplikacją OpenGL Extensions Viewer moją wersje OpenGL i wychodzi na to że jest w wersji 3.1
Ktoś może coś doradzić ? :)

Obrazek
Obrazek
Obrazek



Tagi:


bartekn86
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 6
Posty: 236
Rejestracja: 30 kwie 2018, 20:24
Lokalizacja: Radzionkow
Kontakt:

Re: PikoCNC 5.0.0 i OpenGL

#2

Post napisał: bartekn86 » 05 lip 2020, 14:17

hej, czy ktos ma jakies informacje w sprawie poprawienia błędów tego wyżej i tych dużych stl ?


tad1
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 1
Posty: 141
Rejestracja: 17 sty 2008, 20:01
Lokalizacja: skawa

Re: PikoCNC 5.0.0 i OpenGL

#3

Post napisał: tad1 » 07 lip 2020, 09:19

Ras pisze:Brak podglądu !
karta graficzna nie obsługuje OpenGL >= 1.5

Ja mam tak samo ,na razie nie korzystam z najnowszej wersji ,ale przydałoby się .
Tadek

Awatar użytkownika

cosimo
Specjalista poziom 2 (min. 300)
Specjalista poziom 2 (min. 300)
Posty w temacie: 3
Posty: 585
Rejestracja: 21 maja 2008, 10:02
Lokalizacja: Damasławek

Re: PikoCNC 5.0.0 i OpenGL

#4

Post napisał: cosimo » 07 lip 2020, 14:01

PikoCNC 5.0.0 po uruchomieniu wyświetla taki komunikat
Brak podglądu !
Masz WIN10, a z tego co widzę, to chyba nawet nie ma driver-ów do 10 dla tej grafiki. Próbowałeś uruchamiać program w trybie zgodności z WIN8 ?
BlueScreen z info o braku tej wersji OpenGL będzie wtedy gdy w bibliotece OpenGL32.dll nie będzie odpowiedniej funkcji, lub w ogóle nie będzie tej biblioteki w systemie.
Niestety nie mam nic z taką grafiką aby przetestować ten przypadek.

Awatar użytkownika

LWi
Nowy użytkownik, używaj wyszukiwarki
Nowy użytkownik, używaj wyszukiwarki
Posty w temacie: 2
Posty: 7
Rejestracja: 08 lip 2020, 18:17

Re: PikoCNC 5.0.0 i OpenGL

#5

Post napisał: LWi » 08 lip 2020, 19:26

W PICO 5 jest błąd w komunikacie. Powinno być że wymagana jest biblioteka GLSL w wersji powyżej 1.5 a to oznacza że wymagana wersja openGL to min 3.2 . Ta karta ma wersję 3.1 i nie zadziała.


Autor tematu
Ras
Nowy użytkownik, używaj wyszukiwarki
Nowy użytkownik, używaj wyszukiwarki
Posty w temacie: 2
Posty: 2
Rejestracja: 28 cze 2020, 11:30

Re: PikoCNC 5.0.0 i OpenGL

#6

Post napisał: Ras » 10 lip 2020, 20:35

cosimo pisze:
07 lip 2020, 14:01
PikoCNC 5.0.0 po uruchomieniu wyświetla taki komunikat
Brak podglądu !
Masz WIN10, a z tego co widzę, to chyba nawet nie ma driver-ów do 10 dla tej grafiki. Próbowałeś uruchamiać program w trybie zgodności z WIN8 ?
BlueScreen z info o braku tej wersji OpenGL będzie wtedy gdy w bibliotece OpenGL32.dll nie będzie odpowiedniej funkcji, lub w ogóle nie będzie tej biblioteki w systemie.
Niestety nie mam nic z taką grafiką aby przetestować ten przypadek.
Dzięki za odpowiedź
Wydaje mi się że już próbowałem w trybie zgodności z WIN8.
Jak bym do testów podesłał sprzęt to czy istnieje wtedy opcja że pomógł bym jakoś w rozwoju i rozwiązaniu problemu u więcej osób, czy po prostu moja karta graficzna jest za słaba i nie ma sensu się z tym bawić ?

Dodane 2 minuty 58 sekundy:
LWi pisze:
08 lip 2020, 19:26
W PICO 5 jest błąd w komunikacie. Powinno być że wymagana jest biblioteka GLSL w wersji powyżej 1.5 a to oznacza że wymagana wersja openGL to min 3.2 . Ta karta ma wersję 3.1 i nie zadziała.
Dzięki,
jeśli tak jest no to jednym słowem nic nie zrobię i mamy odpowiedź :)

Awatar użytkownika

cosimo
Specjalista poziom 2 (min. 300)
Specjalista poziom 2 (min. 300)
Posty w temacie: 3
Posty: 585
Rejestracja: 21 maja 2008, 10:02
Lokalizacja: Damasławek

Re: PikoCNC 5.0.0 i OpenGL

#7

Post napisał: cosimo » 10 lip 2020, 21:34

W PICO 5 jest błąd w komunikacie. Powinno być że wymagana jest biblioteka GLSL w wersji powyżej 1.5 a to oznacza że wymagana wersja openGL to min 3.2 . Ta karta ma wersję 3.1 i nie zadziała.
Ale tu chodzi właśnie o wersje OpenGL a nie GLSL. Wersja 1.5 powstała w 2003 r. https://www.khronos.org/opengl/wiki/History_of_OpenGL
Jak bym do testów podesłał sprzęt to czy istnieje wtedy opcja że pomógł bym jakoś w rozwoju i rozwiązaniu problemu u więcej osób, czy po prostu moja karta graficzna jest za słaba i nie ma sensu się z tym bawić ?
Jak chcesz - można zobaczyć czego tam brakuje. Nie jest to takie stare i w zasadzie powinno działać.


bartekn86
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 6
Posty: 236
Rejestracja: 30 kwie 2018, 20:24
Lokalizacja: Radzionkow
Kontakt:

Re: PikoCNC 5.0.0 i OpenGL

#8

Post napisał: bartekn86 » 11 lip 2020, 10:39

Chłopaki, tak offtopicowo, jak to jest z tym openglem w końcu ? nie jest to tak ze do wersji 4 ( i chyba dx11) wszystko bylo projektowane do użycie jednego rdzenia ? jest to obserwowalne w module cam - obracając 100 megowym stlem który już ma wygenerowaną ścieżkę narzędzia widać ewidentnie że cpu mieli jednym rdzeniem.

Skoro te symulacje/wizualizacje potrzebują "normalnej" karty - ja zadowalającą (nie mylić z pożądaną) płynność uzyskałem dopiero na amd rx580 to może warto przenieść render na coś współczesnego i starocie (karty graf) które nie mają swojej pamięci, które mają i tak bardzo małą wydajność, (nikłą w zasadzie) po prostu odciąć ? takie api vulkan to jest bardzo mocno rozwojowe zdecydowanie lepiej potrafi wykorzystać hardware i w zasadzie jest między platformowe i wymusiło by użycie współczesnego sprzętu ?

Awatar użytkownika

grg12
ELITA FORUM (min. 1000)
ELITA FORUM (min. 1000)
Posty w temacie: 1
Posty: 1240
Rejestracja: 03 sty 2007, 14:27
Lokalizacja: Wiedeń

Re: PikoCNC 5.0.0 i OpenGL

#9

Post napisał: grg12 » 11 lip 2020, 16:28

Z ciekawości - pisałeś coś pod Vulkan? Przedzieram się właśnie przez tutorial SDK - zwykle "przechodzę" tego typu tutoriale przepisując kod po swojemu (żeby zrozumieć o co biega i zacząć grupować funkcjonalności po swojemu) i jak do tej pory jest to najbardziej frustrujący tutorial jaki znam - 140kB kodu zanim w końcu udało mi się wyświetlić tą nieszczęsną kostkę...
Porównując to z OpenGL gdzie bardzo prosto i szybko dało się "coś" narysować a potem stopniowo poszerzać i eksperymentować z programem Vulkan ma bardzo stromą krzywą uczenia się.


bartekn86
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 6
Posty: 236
Rejestracja: 30 kwie 2018, 20:24
Lokalizacja: Radzionkow
Kontakt:

Re: PikoCNC 5.0.0 i OpenGL

#10

Post napisał: bartekn86 » 11 lip 2020, 17:11

Niestety,temat dla mnie jest za skomplikowany ale sens pytania złapałem. Może faktycznie kopanie się z koniem nie jest warte gry. Martwi mnie to że możliwym ograniczeniem szybkości renderu w module cam jest api a nie moc komputera.
Jezeli do tego trzeba kupić quadro firepro albo inne pro za 2k pln to nie jest to problem, tylko musi być pewność że to będzie działać.
Po tej aktualizacji do wersji 5.0 w porównania z poprzednią wersją juz jest zdecydowanie lepiej

ODPOWIEDZ Poprzedni tematNastępny temat

Wróć do „PikoCNC”