X jedzie tylko w jedna stronę :)

Dyskusje dotyczące działania obsługi programu CNConv

Autor tematu
oprawcafotografii
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 3
Posty: 5048
Rejestracja: 29 kwie 2009, 10:11
Lokalizacja: Kraków / Jaworzno / Kopanka

X jedzie tylko w jedna stronę :)

#1

Post napisał: oprawcafotografii » 09 lip 2020, 12:18

Hej :)

Odpalam starą maszynkę z CNConv i nie pamiętam jak to ogarnąć ;)

Trafiłem na problem taki, że X jeździ mi tylko w jedna stronę.
Gdy zmienię kolejność Step/Dir jedzie w drugą stronę (ale też jedną).

Zmieniłem kanały w sterowniku - to samo. Wygląda na to, że na piny
2 i 3 wysyłane są złe sygnały?! Co ciekawe jazda strzałką wygląda tak,
że w jedna stronę oś jedzie z przyspieszeniem, w drugą bez.

Wydaje mi się, że już to przerabiałem, ale nie pamiętam WTF :)

Podpowiecie?

Jakub


www.youtube.com/watch?v=rVr2Qkb_0Ko

Awatar użytkownika

zzzZZZ
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 2
Posty: 179
Rejestracja: 14 cze 2018, 13:09
Lokalizacja: Piwnica
Kontakt:

Re: X jedzie tylko w jedna stronę :)

#2

Post napisał: zzzZZZ » 09 lip 2020, 12:44

zmiana step/dir w sensie, że zamieniasz wpinasz jedno w drugie?
Jeśli dir wstawisz w step to powinien na wyjściu by ciągle 0 lub 1 więc ruch się nie powinien odbywać. Sprawdź miernikiem na dir czy dla zmiany kierunku pojawia zmienia się sygnał. Może jakiś przewód nie łączy albo wyjście z kontrolera
wszystko jest trudne zanim stanie się łatwe


Autor tematu
oprawcafotografii
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 3
Posty: 5048
Rejestracja: 29 kwie 2009, 10:11
Lokalizacja: Kraków / Jaworzno / Kopanka

Re: X jedzie tylko w jedna stronę :)

#3

Post napisał: oprawcafotografii » 09 lip 2020, 13:47

Już mam - coś w programie. Wgrałem wersje o oczko nowszą i bangla :)

q
www.youtube.com/watch?v=rVr2Qkb_0Ko

Awatar użytkownika

zzzZZZ
Specjalista poziom 1 (min. 100)
Specjalista poziom 1 (min. 100)
Posty w temacie: 2
Posty: 179
Rejestracja: 14 cze 2018, 13:09
Lokalizacja: Piwnica
Kontakt:

Re: X jedzie tylko w jedna stronę :)

#4

Post napisał: zzzZZZ » 09 lip 2020, 14:21

a jakiej wersji używałeś? tak dla potomnych co może będą mieli taki sam problem
wszystko jest trudne zanim stanie się łatwe


gozdd
Specjalista poziom 2 (min. 300)
Specjalista poziom 2 (min. 300)
Posty w temacie: 1
Posty: 592
Rejestracja: 02 gru 2013, 19:21
Lokalizacja: Częstochowa

Re: X jedzie tylko w jedna stronę :)

#5

Post napisał: gozdd » 09 lip 2020, 14:39

Jeśli po podmianie przewodów dalej jechało, to sterowanie CW/CCW, a nie Step/Dir.


Autor tematu
oprawcafotografii
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 3
Posty: 5048
Rejestracja: 29 kwie 2009, 10:11
Lokalizacja: Kraków / Jaworzno / Kopanka

Re: X jedzie tylko w jedna stronę :)

#6

Post napisał: oprawcafotografii » 12 lip 2020, 11:29

Hej

To jednak nie kwestia wersji, a jakiegoś "dziwnego stanu" w który wpada sterownik.
Jest to chyba związane z tym w jakim stanie konfiguracji uruchomi się program -
czy osie nie będą logicznie "poza zakresem" etc. Nie potrafię dokładnie zidentyfikować
sytuacji. W każdym razie pomaga ...zbazowanie. Trzeba problematyczną oś przesunąć
w bezpieczna pozycję (np. nie na krańcówce ;)), nawet gdyby trzeba było w programie
odwracać kierunek jazdy i potem puścić bazowanie. Wszystko wraca do normy.

Nie wiem, czy mam w 100% rację w każdym razie działa ;)

q
www.youtube.com/watch?v=rVr2Qkb_0Ko

ODPOWIEDZ Poprzedni tematNastępny temat

Wróć do „CNConv”