Dziwne zachowanie silnika krokowego

Dyskusje na temat silników krokowych i sterowników silników krokowych.

Autor tematu
spamet
Nowy użytkownik, używaj wyszukiwarki
Nowy użytkownik, używaj wyszukiwarki
Posty w temacie: 2
Posty: 2
Rejestracja: 01 cze 2018, 13:31

Dziwne zachowanie silnika krokowego

#1

Post napisał: spamet » 01 cze 2018, 13:52

Witam

Do starego plotera chcę założyć nowy silnik krokowy FL86STH118-6004A. Sterownik MD882.
I wszytko chodzi, znaczy kręci się, tylko że silnik po zmianie kierunku rusza, zwalnia na chwilę, przyspiesza, jeszcze raz zwalnia i dopiero kręci się normalnie. Kolejne zatrzymania i start są już normalne, ale kolejna zmiana kierunku pracy to zwolnienie obrotów.
Ktoś wie co może byt tego przyczyną?
Dodam że wszystkim steruje mah3.




ArkoBro
Czytelnik forum poziom 1 (min. 10)
Czytelnik forum poziom 1 (min. 10)
Posty w temacie: 1
Posty: 14
Rejestracja: 11 maja 2018, 15:08

Re: Dziwne zachowanie silnika krokowego

#2

Post napisał: ArkoBro » 02 cze 2018, 16:37

Co to znaczy "zwalnia na chwilę"? Jaki jest powód zakładania nowego silnika? Czy wcześniej było ok na tym sterowniku oraz programie sterującym? Mach3 bezpośrednio przez "pusty" optobob lpt, czy przez jakis kontroler etnernet/usb? Jeżeli masz możliwość podmień sterowniki/silnik z innej osi. Mach3 też lubi odwalić podobne numery, ale czekam na dokładniejsze dane.


Autor tematu
spamet
Nowy użytkownik, używaj wyszukiwarki
Nowy użytkownik, używaj wyszukiwarki
Posty w temacie: 2
Posty: 2
Rejestracja: 01 cze 2018, 13:31

Re: Dziwne zachowanie silnika krokowego

#3

Post napisał: spamet » 04 cze 2018, 11:53

Witam
1. "zwalnia na chwilę" znaczy obroty silnika spadają prawie do zera.
2. Do tej pory wszystko chodziło OK. Postanowiłem dołożyć drugi silnik do osi X napędzający 2,5m bramę . Silnik osi X jest umieszczony z lewej strony bramy. Na osi silnika zębatka fi 20 napędza koło zębate fi 80 Z53 M1,5 które jeździ po listwie zębatej. Po drugiej stronie też koło zębate fi 80 Z53 M1,5 jeżdżące po listwie zębatej, Przeniesienie napędu na prawą stronę bramy odbywa się przez wałek i przekładnie z paskiem zębatym. A to powoduje nierównomierny ruch bramy. Po zmianie kierunku strona prawa rusza z „małym” opóźnieniem. Po modernizacji chcę aby w osi X pracowały 2 identyczne silniki z obu stron bramy podpięte pod dwa identyczne sterownik i napędzały istniejące koła zębate i były sterowane równolegle z wyjścia X płyty głównej. Czy 2 sterowniki mogą być sterowane z 1 wyjścia płyty? czy trzeba nową płytę główną (np SSK-MB2 )

Zgodnie z radą podmieniałem silniki i sterowniki. Problem ze startem po zmianie kierunku pojawia się tylko na sterownikach podpiętych do wyjścia X płyty głównej SSK-MB. Płyta z komp. podpięta przez port lpt. Czy to uszkodzona płyta główna?


Steryd
Specjalista poziom 3 (min. 600)
Specjalista poziom 3 (min. 600)
Posty w temacie: 1
Posty: 923
Rejestracja: 13 lut 2017, 19:34
Lokalizacja: Szczecin

Re: Dziwne zachowanie silnika krokowego

#4

Post napisał: Steryd » 04 cze 2018, 15:47

Jeśli już, to podłącz dwa silniki do jednego sterownika, tylko musisz prąd dopasować...
Można?
Morzna!!!

ODPOWIEDZ Poprzedni tematNastępny temat

Wróć do „Silniki Krokowe / Sterowniki Silników Krokowych”