CNC grbl 0,9j zablokowane silniki krokowe

Dyskusje o programowaniu mikroprocesorów.

Autor tematu
michall-1981
Czytelnik forum poziom 1 (min. 5)
Czytelnik forum poziom 1 (min. 5)
Posty w temacie: 5
Posty: 5
Rejestracja: 19 cze 2017, 17:09
Lokalizacja: konin

CNC grbl 0,9j zablokowane silniki krokowe

#1

Post napisał: michall-1981 » 19 cze 2017, 17:18

Witam
Buduje frezarkę -grawerkę itd jak zwał tak zwał sterowanie 3 osie opiera się to wszytko na mega 328p i do tego a 4988 i silniki 17 hs4401 mam problem z ustawieniami $1 steps idle delay, msec - jak w temacie po załączeniu zasilania 24VDC silniki od razu są zahamowane zmiany w $1 nic nie dają czy to normalne ?



Tagi:


upanie
ELITA FORUM (min. 1000)
ELITA FORUM (min. 1000)
Posty w temacie: 8
Posty: 1126
Rejestracja: 15 sty 2011, 09:26
Lokalizacja: Wyszków

#2

Post napisał: upanie » 19 cze 2017, 23:46

Może masz enable odwrotnie sterowane.
Wrzuć ustawienia, wynik polecenia $$
Poza tym dlaczego 0.9j a nie 1.1?
Ja w 0.9g miałem dziwne problemy z ustawieniami i gubieniem konfiguracji w EPROM.
Nowszego nie sprawdzałem bo i nie mam kiedy ale jest szansa, że jest poprawiony.
czilałt...


michall-1981@tlen.pl
Posty w temacie: 5

#3

Post napisał: michall-1981@tlen.pl » 20 cze 2017, 14:18

$0=5 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=1 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=5 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=1066.000 (x, step/mm)
$101=1066.000 (y, step/mm)
$102=1066.000 (z, step/mm)
$110=800.000 (x max rate, mm/min)
$111=800.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)


upanie
ELITA FORUM (min. 1000)
ELITA FORUM (min. 1000)
Posty w temacie: 8
Posty: 1126
Rejestracja: 15 sty 2011, 09:26
Lokalizacja: Wyszków

#4

Post napisał: upanie » 20 cze 2017, 14:22

Tak jak napisałem masz odwrócony sygnał enable.
$4 powinien być 0 czyli polecenie $4=0
czilałt...


michall-1981@tlen.pl
Posty w temacie: 5

#5

Post napisał: michall-1981@tlen.pl » 20 cze 2017, 14:24

Zmiana $1 na 0 i zmiana $4 na 0 nie ma różnicy. nie znam grbl 1.1 może zobaczę nie mam doświadczenia ale sprobuje ale najpierw poczekam na odpowiedź :-)


michall-1981@tlen.pl
Posty w temacie: 5

#6

Post napisał: michall-1981@tlen.pl » 20 cze 2017, 14:27

po zmianach ;-)
**** Connected to COM4 @ 115200 baud ****

Grbl 0.9j ['$' for help]
>>> $$
$0=5 (step pulse, usec)
$1=0 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=5 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=1066.000 (x, step/mm)
$101=1066.000 (y, step/mm)
$102=1066.000 (z, step/mm)
$110=800.000 (x max rate, mm/min)
$111=800.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)


michall-1981@tlen.pl
Posty w temacie: 5

#7

Post napisał: michall-1981@tlen.pl » 20 cze 2017, 14:27

po zmianach ;-)
**** Connected to COM4 @ 115200 baud ****

Grbl 0.9j ['$' for help]
>>> $$
$0=5 (step pulse, usec)
$1=0 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=0 (dir port invert mask:00000000)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=5 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=1066.000 (x, step/mm)
$101=1066.000 (y, step/mm)
$102=1066.000 (z, step/mm)
$110=800.000 (x max rate, mm/min)
$111=800.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)


upanie
ELITA FORUM (min. 1000)
ELITA FORUM (min. 1000)
Posty w temacie: 8
Posty: 1126
Rejestracja: 15 sty 2011, 09:26
Lokalizacja: Wyszków

#8

Post napisał: upanie » 20 cze 2017, 14:28

No to coś sknociłeś w połączeniach.
1.1 to to samo tylko rozszerzone o nowe gkody.

[ Dodano: 2017-06-20, 15:30 ]
Może też być błąd w programie ale coś mało w to wierzę.
U mnie0.9g nie reagowało na zmianę polaryzacji krańcówek.
czilałt...


Autor tematu
michall-1981
Czytelnik forum poziom 1 (min. 5)
Czytelnik forum poziom 1 (min. 5)
Posty w temacie: 5
Posty: 5
Rejestracja: 19 cze 2017, 17:09
Lokalizacja: konin

#9

Post napisał: michall-1981 » 20 cze 2017, 14:35

to jest gotowy grbl 0.9 j kupiłem i podłączyłem ale gdzie w trakcie testów siadł mi sterownik silnika krokowego a4988 wymieniłem i wszystko ok z tym tylko jednym problemem o którym mowa..


upanie
ELITA FORUM (min. 1000)
ELITA FORUM (min. 1000)
Posty w temacie: 8
Posty: 1126
Rejestracja: 15 sty 2011, 09:26
Lokalizacja: Wyszków

#10

Post napisał: upanie » 20 cze 2017, 14:38

Jeśli masz możliwość to sprawdź czy przypadkiem pin enable.nie jest zwarty do masy albo vcc.
czilałt...

ODPOWIEDZ Poprzedni tematNastępny temat

Wróć do „Arduino, Raspberry pi i inne systemy mikroprocesorowe”