Problem z laptopem / linuxCNC / portem LPT

Dyskusje dotyczące działania obsługi programu LinuxCNC

Autor tematu
emblaze
Nowy użytkownik, używaj wyszukiwarki
Nowy użytkownik, używaj wyszukiwarki
Posty w temacie: 2
Posty: 2
Rejestracja: 17 cze 2022, 21:48

Problem z laptopem / linuxCNC / portem LPT

#1

Post napisał: emblaze » 17 cze 2022, 22:08

Siemanko,
mam w warsztacie małą tokarkę własnej roboty sterowaną po LPT z laptopa IBM T43 z LinuxCNC (płytka sterownicza CNC LPT, taka najtańsza zielona za 40zł). Wszystko ładnie śmigało aż do dzisiaj - na początku laptop coś nie chciał odpalić systemu - jakiś błąd wyskoczył związany z potrzebą ręcznego sprawdzenia dysku. Komenda fcsk załatwiła sprawę. Po odpaleniu systemu LinuxCNC nie jest w stanie się połączyć z maszyną. Nie da się wyłączyć "estopu - f1" i włączyć maszyny "f2" z poziomu laptopa. Sama elektronika w szafie działa bo krokowce trzymają osie. Do dziś wszystko śmigało cacy. Mam też drugi system - windows xp na innej partycji i zdaje się, że Mach3 którego tam mam zainstalowanego też nie jest w stanie skomunikować się z maszyną. Ktoś jest w stanie mnie jakoś nakierować jak zdiagnozować czy to wina portu w laptopie czy też samego sterownika CNC? A może coś innego co przeoczyłem? Nie mam już pomysłu jak to zdiagnozować nie wymieniając komputera / płytki sterującej. Dodam, że wbiłem z poziomu windowsa w menedżera urządzeń i niby jest informacja, że port LPT działa prawidłowo, ale nie wiem, czy można temu wierzyć. :roll:




Steryd
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 1
Posty: 3298
Rejestracja: 13 lut 2017, 19:34
Lokalizacja: Szczecin

Re: Problem z laptopem / linuxCNC / portem LPT

#2

Post napisał: Steryd » 17 cze 2022, 22:35

Sprawdź w biosie, czy port LPT jest ustawiony w tryb ECP/EPP
Może bateria padła i przywróciły się wartości domyślne.
Można?
Morzna!!!


Autor tematu
emblaze
Nowy użytkownik, używaj wyszukiwarki
Nowy użytkownik, używaj wyszukiwarki
Posty w temacie: 2
Posty: 2
Rejestracja: 17 cze 2022, 21:48

Re: Problem z laptopem / linuxCNC / portem LPT

#3

Post napisał: emblaze » 18 cze 2022, 12:38

Faktycznie, bateria chyba padła od biosu i zmienił się tryb oraz adres portu LPT - zmiana tych dwóch ustawień załatwiła sprawę. Dzięki wielkie!

ODPOWIEDZ Poprzedni tematNastępny temat

Wróć do „LinuxCNC (dawniej EMC2)”