Piko i silniki hybrydowe

Dyskusje dotyczące działania obsługi programu PikoCNC

Autor tematu
Michal3013
Sympatyk forum poziom 1 (min. 40)
Sympatyk forum poziom 1 (min. 40)
Posty w temacie: 7
Posty: 49
Rejestracja: 25 maja 2020, 07:14

Re: Piko i silniki hybrydowe

#11

Post napisał: Michal3013 » 03 kwie 2022, 01:11

Rozumiem, ale problem się pojawiał się już kilkukrotnie. Np przy posuwie 1500mm/min na odcinku 240mm potrafi pojechać dalej, zbieram po 0,5mm i na max 1200mm/min w alu. To dużo?
Mechanicznie jest git



Awatar użytkownika

TOP67
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 6
Posty: 2224
Rejestracja: 17 wrz 2018, 10:47
Lokalizacja: Wrocław
Kontakt:

Re: Piko i silniki hybrydowe

#12

Post napisał: TOP67 » 03 kwie 2022, 01:27

Co znaczy pojechać dalej? Więcej niż powinien?
Gubienie kroków objawia się zwykle zmniejszeniem przebytej drogi.
Oczywiście ciężkiego wrzeciona nie da się zatrzymać w miejscu. Zwłaszcza na pasku. Ale od tego jest rampa. Warto też sprawdzić czy silnik ma odpowiedni prąd trzymający. Może za szybko wyłącza się sygnał Enable?


Autor tematu
Michal3013
Sympatyk forum poziom 1 (min. 40)
Sympatyk forum poziom 1 (min. 40)
Posty w temacie: 7
Posty: 49
Rejestracja: 25 maja 2020, 07:14

Re: Piko i silniki hybrydowe

#13

Post napisał: Michal3013 » 03 kwie 2022, 01:42

A to nie wiem jak to sprawdzić. A w Xie potrafi przeskoczyć o kilka mm i już tak kontynuuje. Przykład z dziś, przesunięcie o 4mm na detalu długości 70mm

Dodane 1 minuta :
W sensie, przesunięcie pomiędzy detalami. Mocowanie w imadle do dokładu


bartekn86
Specjalista poziom 2 (min. 300)
Specjalista poziom 2 (min. 300)
Posty w temacie: 3
Posty: 375
Rejestracja: 30 kwie 2018, 20:24
Lokalizacja: Radzionkow
Kontakt:

Re: Piko i silniki hybrydowe

#14

Post napisał: bartekn86 » 03 kwie 2022, 07:24

Zwolnij obróbkę tak jak koledzy zasugerowali i zobacz czy Ci to pomoże,
Jak jesteś gdzieś z okolic to wpadnij
8,5nM w hybrydzie wyrabia przy 5000mm/min z przyspieszeniem 4ms^2 z bramą ważącą brutto okolo 50kg

Awatar użytkownika

TOP67
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 6
Posty: 2224
Rejestracja: 17 wrz 2018, 10:47
Lokalizacja: Wrocław
Kontakt:

Re: Piko i silniki hybrydowe

#15

Post napisał: TOP67 » 03 kwie 2022, 08:02

Michal3013 pisze:
03 kwie 2022, 01:42
A to nie wiem jak to sprawdzić. A w Xie potrafi przeskoczyć o kilka mm i już tak kontynuuje. Przykład z dziś, przesunięcie o 4mm na detalu długości 70mm

Dodane 1 minuta :
W sensie, przesunięcie pomiędzy detalami. Mocowanie w imadle do dokładu
Czyli sam detal jest zrobiony OK, tylko w złym miejscu? To by sugerowało problem przy G0, czyli ustawiona za duża szybkość maksymalna maszyny. Przy małych odcinkach nie zdąży się rozpędzić.
Przetestuj maksymalną prędkość na dłuższym odcinku. Z punktu 0 pojedź na koniec komendą G0, a wróć G1 F500. Trafi w to samo miejsce? Najlepiej zegarem, ale można też nawiercić mały otwór w punkcie startu i sprawdzić czy trafia.


Autor tematu
Michal3013
Sympatyk forum poziom 1 (min. 40)
Sympatyk forum poziom 1 (min. 40)
Posty w temacie: 7
Posty: 49
Rejestracja: 25 maja 2020, 07:14

Re: Piko i silniki hybrydowe

#16

Post napisał: Michal3013 » 03 kwie 2022, 08:44

Detal jest ok, już robiłem kiedyś taką próbę. Sypał się przy predkook 3300mm/min I to sporadycznie

Dodane 7 minuty 4 sekundy:
To teraz jeszcze inna sprawa, czy jak wyłączę program. Maszyna jeszcze jest włączona, to silnik powinien być,,luźny,, tzn da się go bez problemu przekręcić palcem? Czy powinien stawiać opór?
W moim przypadku X jest luźny a i Y I Z stawiają opór


bartekn86
Specjalista poziom 2 (min. 300)
Specjalista poziom 2 (min. 300)
Posty w temacie: 3
Posty: 375
Rejestracja: 30 kwie 2018, 20:24
Lokalizacja: Radzionkow
Kontakt:

Re: Piko i silniki hybrydowe

#17

Post napisał: bartekn86 » 03 kwie 2022, 08:49

rozsprzęgl silnik z maszyną i zobacz gdzie faktycznie jest problem, czy w mechanice czy w podłączeniu sygnałów enable z piko na drivery

Awatar użytkownika

TOP67
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 6
Posty: 2224
Rejestracja: 17 wrz 2018, 10:47
Lokalizacja: Wrocław
Kontakt:

Re: Piko i silniki hybrydowe

#18

Post napisał: TOP67 » 03 kwie 2022, 08:58

To może być powód tego, że oś X jedzie za daleko. Nie ma hamowania i wrzeciono rozpędem jedzie dalej. To jeszcze zależy od rodzaju napędu. Na pasku lub śrubie kupowej o dużym skoku, bez problemu. Ale już trapezowa powinna być samohamująca.

Dlatego silniki powinny trzymać. Ale to zależy też od konfiguracji programu. Dla oszczędności prądu po jakimś czasie wyłącza się prąd trzymający. Ale raczej we wszystkich osiach jednakowo.
Sprawdź jeszcze czy jak pracuje tylko oś Y, to możesz poruszyć silnikiem X. Nie powinno to być możliwe.


Autor tematu
Michal3013
Sympatyk forum poziom 1 (min. 40)
Sympatyk forum poziom 1 (min. 40)
Posty w temacie: 7
Posty: 49
Rejestracja: 25 maja 2020, 07:14

Re: Piko i silniki hybrydowe

#19

Post napisał: Michal3013 » 03 kwie 2022, 09:41

Śruby kulowe 16x5, mechanicznie jest ok. Sprawdzałem już to na całej długości osi X

Awatar użytkownika

tuxcnc
Lider FORUM (min. 2000)
Lider FORUM (min. 2000)
Posty w temacie: 1
Posty: 6291
Rejestracja: 26 lut 2011, 23:24
Lokalizacja: mazowieckie

Re: Piko i silniki hybrydowe

#20

Post napisał: tuxcnc » 03 kwie 2022, 09:51

Michal3013 pisze:
03 kwie 2022, 01:42
A to nie wiem jak to sprawdzić
Weź dobrego markera i narysuj linię przez śrubę, sprzęgło, oś i obudowę silnika,
Potem rób, z różną prędkością i rampą, ruchy o wielokrotność pełnego skoku śruby, czyli pełnych obrotów silnika.
Od razu zobaczysz gdzie Ci się kreski rozjadą.

ODPOWIEDZ Poprzedni tematNastępny temat

Wróć do „PikoCNC”